MI 3.2 does not recognize hard key

MI 3.2 does not recognize hard key

Postby Testman » Thu Oct 03, 2013 1:35 pm

MI 3.2 does not recognize hard key

Yesterday I ran MI 3.2 on my work computer with no problem.

Today, when I ran MI, I acciently did so without having my usb hardkey connected. MI brought up a dialog asking for an activation code.

I realized what I had done wrong, exited MI, inserted the usb key, and ran MI again --> same result.

I logged out of windows, logged back in, ran MI (key still inserted) --> same result.

I shutdown my computer, started my computer, logged in, ran MI (key still inserted) --> same result.

Please advise how I can get around this problem and force MI to recognize the hard key instead of asking for an activation code.

James Vasil

p.s. I started this thread in the Questions forum since I thought you might not consider this a bug (although I do :-).

Post at 22-6-2011 01:35

Please follow the steps below to diagnose:

1. When you plug the USB hardkey into a USB port, it should light-up, blink for one time, then keep lighting up. Otherwise, it might be damaged.

2. To check whether the software is able to recognize the USB hardkey, under Windows desktop, click [Start]>[All Programs]>[Multi-Instrument]>[VIRTINS Hardware Upgrading Tool]. If "No hardware detected!" is displayed, then the USB hardkey is not recognizable. Close the VIRTINS Hardware Upgrading Tool.

3. Please check the software installation directory to see if you can find the three executables, MI.exe, MIs.exe, MIu.exe. Run MIu.exe to see whether the software can start successfully with the USB hardkey attached. If nothing happens, then right click MI.exe and choose "Run as administrator".

Post at 22-6-2011 02:11

1. Yes, LED lit up, blinked once, stayed lit.

2. The VIRTINS Hardware Upgrade Tool does see the key and says "USB hardkey detected".

3. Yes, all three exes are there. MI starts normally when I run MIu.exe.

Now that I've done those steps, MI also starts normally when I run MI.exe or the shortcut to same that I tried using earlier.

NOTE: In between my first post and now, I also tried uninstalling MI (with revouninstaller) and restalling same. However, after doing this attempting to run MI still brought up the activation dialog.

But it looks like the problem is fixed--at least for now. Thank you for your quick response.

Post at 22-6-2011 02:54
Posts: 52
Joined: Wed Oct 02, 2013 9:51 pm

Return to Questions

Who is online

Users browsing this forum: No registered users and 1 guest